Hides the element group's attached detail groups of the input group type that are compatible with the input view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2019.1
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DB View
The view that the attached detail groups must be compatible with.
- detailGroupTypeId
- Type: Autodesk.Revit.DB ElementId
Only attached detail groups of this type will be hidden.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The attached detail group detailGroupTypeId does not match the input view's orientation. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | The input group is not a model group and can therefore not have attached detail groups. |