GetRebarInSystemIds Method


Returns the ids of the RebarInSystem elements owned by the PathReinforcement element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013

Syntax

C#
public IList<ElementId> GetRebarInSystemIds()
Visual Basic
Public Function GetRebarInSystemIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetRebarInSystemIds()

Remarks

The RebarInSystem elements are only created if ReinforcementSettings.HostStructuralRebar is set to true. If that setting is false, this function returns an empty array.

See Also