Checks whether the facilities of this class are available for use in the current scope.
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
True if the DrawContext is available for rendering, false otherwise.Remarks
This class can perform drawing operations and access the state of parameters related to drawing only in lock-step with rendering inside of Revit. As a consequence, the facilities of this class are not available for use outside of the scope determined by the callback RenderScene(View, DisplayStyle) . Certain methods of other DirectContext3D objects, e.g., VertexBuffer::Map() are similarly restricted by the same scope.