NextCurveType Property


The HorizontalCurveType of the curve which connects the endpoint to the next displayed curve. If this endpoint's Station equals DisplayedEndStation , returns Unknown curve type.

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021.1

Syntax

C#
public HorizontalCurveType NextCurveType { get; internal set; }
Visual Basic
Public Property NextCurveType As HorizontalCurveType
	Get
	Friend Set
Visual C++
public:
property HorizontalCurveType NextCurveType {
	HorizontalCurveType get ();
	internal: void set (HorizontalCurveType value);
}

See Also