Checks that an ExternalDefinition (shared parameter) may be used as a Rebar Shape parameter.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- param
- Type: Autodesk.Revit.DB ExternalDefinition
Definition of a shared parameter.
Return Value
True if the definition is of type Length, false otherwise.Remarks
A Rebar Shape parameter must be an ExternalDefinition with a ParameterType of Length.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was a null reference ( Nothing in Visual Basic) |