UpDirection Property


Direction along the vertical axis of letters of the text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)

Syntax

C#
public XYZ UpDirection { get; }
Visual Basic
Public ReadOnly Property UpDirection As XYZ
	Get
Visual C++
public:
property XYZ^ UpDirection {
	XYZ^ get ();
}

Remarks

This vector points up from the base of the letters and is always perpendicular to the base direction. Those two vectors together define the plane of the text.

See Also