Returns a reference to a given curve within the analytical model.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- selector
- Type: Autodesk.Revit.DB.Structure AnalyticalModelSelector
Specifies where in the analytical model the reference lies.
Return Value
Requested reference.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | selector is not valid for this AnalyticalModel. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |