The method that Revit will invoke to perform an export to IFC.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document to export.
- exporter
- Type: Autodesk.Revit.DB.IFC ExporterIFC
The IFC exporter object.
- filterView
- Type: Autodesk.Revit.DB View
The view whose filter visibility settings govern the export.
Remarks
There will be a transaction group opened for the document. Any changes made to the document must be temporary, as the transaction group will automatically be rolled back at the end.