Parses a formatted string into a number with units if possible.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- units
- Type: Autodesk.Revit.DB Units
The units formatting settings, typically obtained from Document.GetUnits() .
- specTypeId
- Type: Autodesk.Revit.DB ForgeTypeId
Identifier of the target spec for the value.
- stringToParse
- Type: System String
The string to parse.
- value
- Type: System Double %
The parsed value. Ignore this value if the function returns false.
- message
- Type: System String %
A localized message that, if the parsing fails, explains the reason for failure.
Return Value
True if the string can be parsed, false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |