Offset Property


The offset of the labels from the alignment, in Revit internal paper space units (standard Imperial feet). A positive offset creates labels to the right of the alignment, a negative - to the left. The default value is null. If null, a predefined offset value will be used, depending on the unit setting for stationing units in the document. For standard imperial, the default is 1/8". For survey imperial, the default is 1/8" (US survey). For metric, the default is 5 mm.

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021.1

Syntax

C#
public Nullable<double> Offset { get; set; }
Visual Basic
Public Property Offset As Nullable(Of Double)
	Get
	Set
Visual C++
public:
property Nullable<double> Offset {
	Nullable<double> get ();
	void set (Nullable<double> value);
}

See Also