GetAllViewports Method


Returns the ElementIds of Viewports on this sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013

Syntax

C#
public ICollection<ElementId> GetAllViewports()
Visual Basic
Public Function GetAllViewports As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAllViewports()

Return Value

The Viewports on this sheet.

Remarks

Schedules on the sheet are not returned by this method. Use ScheduleSheetInstance.OwnerViewId to find the sheet on which a schedule is placed.

See Also