CanAddGeometry Method


A validator function that checks the state of this BRepBuilder object. Returns true if this BRepBuilder object is accepting b-rep data, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016

Syntax

C#
public bool CanAddGeometry()
Visual Basic
Public Function CanAddGeometry As Boolean
Visual C++
public:
bool CanAddGeometry()

Return Value

True if this BRepBuilder object is accepting b-rep data, false otherwise.

Remarks

Use this function before calling AddFace(), AddEdge(), etc. to avoid an exception being thrown.

See Also