The Mass surface subcategory ids that are appropriate values for the input Reference.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- reference
- Type: Autodesk.Revit.DB Reference
A Reference to a Face of this MassEnergyAnalyticalModel.
- recommendedDefaultSubcategoryId
- Type: Autodesk.Revit.DB ElementId %
The ElementId that is recommended as the default setting for this pick.
Return Value
Returns the ElementIds of appropriate values for input Reference.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The Reference is not a Face of this MassEnergyAnalyticalModel. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |