ReportStyle Property


The report style that specifies the display content.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public SystemsAnalysisReportStyle ReportStyle { get; set; }
Visual Basic
Public Property ReportStyle As SystemsAnalysisReportStyle
	Get
	Set
Visual C++
public:
property SystemsAnalysisReportStyle ReportStyle {
	SystemsAnalysisReportStyle get ();
	void set (SystemsAnalysisReportStyle value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also