Gets the flow of this piping system.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
Remarks
The system flow is calculated in the non-blocking evaluation framework. The caller may set up callbacks that react to the asynchronous calculation results. If no callback is set up (e.g, called from third-party applications), the calculation is automatically switched to synchronous calculation so the caller can access the up-to-date result. Similarly, the public method get_ParameterValue(BuiltInParameter.RBS_PIPE_FLOW_PARAM) has the same behavior. Due to this change, the parameter RBS_PIPE_FLOW_PARAM no longer supports dynamic model update.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | The flow can not be calculated for this system. |