GetReferenceNameForHost Method


Gets the name string to be used as a reference to Host in the current language.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020

Syntax

C#
public static string GetReferenceNameForHost()
Visual Basic
Public Shared Function GetReferenceNameForHost As String
Visual C++
public:
static String^ GetReferenceNameForHost()

Return Value

The name string to be used as a reference to Host.

Remarks

This name can be used in the setter for BaseReferenceName or TopReferenceName . The name can also be compared with the value coming from the getter.

See Also