Autodesk.Revit.DB.Analysis Namespace


Classes

Class Description
Public class AnalysisDisplayColoredSurfaceSettings
Contains colored surface settings for analysis display style element.
Public class AnalysisDisplayColorEntry
Contains one entry of intermediate colors in color settings for analysis display style.
Public class AnalysisDisplayColorSettings
Contains color settings for analysis display style element.
Public class AnalysisDisplayDeformedShapeSettings
Contains deformed shape settings for analysis display style element.
Public class AnalysisDisplayDiagramSettings
Contains diagram settings for analysis display style element.
Public class AnalysisDisplayLegend
The legend that describes an Analysis Visualization.
Public class AnalysisDisplayLegendSettings
Contains legend settings for analysis display style element.
Public class AnalysisDisplayMarkersAndTextSettings
Contains markers and text settings for analysis display style element.
Public class AnalysisDisplayStyle
Exposes API for manipulation of analysis display style.
Public class AnalysisDisplayVectorSettings
Contains vector settings for analysis display style element.
Public class AnalysisResultSchema
Contains all information about one analysis result. Each result may contain several measurements.
Public class BuildingEnvelopeAnalyzer
Analyzes which elements are part of the building envelope, the building elements exposed to the outside.
Public class BuildingEnvelopeAnalyzerOptions
Specific options for the method analyzing the building elements for the building envelope.
Public class ConceptualConstructionType
This element is used to describe the conceptual physical, construction, and energy properties in a manner that can be understood by both the Revit BIM model and Green Building Studio/Green Building XML. For serialization
Public class ConceptualSurfaceType
This element represents a conceptual BIM object category to assign to faces in Mass geometries. There is one ConceptualSurfaceType element for each of the Mass Surface Subcategories. for serialization
Public class EnergyAnalysisDetailModel
Manage the analytical thermal model.
Public class EnergyAnalysisDetailModelOptions
Options that govern the calculations for the generation of the energy analysis detail model.
Public class EnergyAnalysisOpening
Analytical opening.
Public class EnergyAnalysisSpace
Analytical space.
Public class EnergyAnalysisSurface
Analytical surface. The collection of analytic openings belonging to this analytical parent surface
Public class EnergyDataSettings
This element contains settings for gbXML Export and Heating and Cooling Load Calculations and project level settings for Conceptual Energy Analysis. for serialization
Public class FieldDomainPoints
Abstract base class for various classes of field domain points
Public class FieldDomainPointsByParameter
Represents a set of one-dimensional point coordinates (defined usually on curve)
Public class FieldDomainPointsByUV
Represents a set of two-dimensional point coordinates (defined usually on surface)
Public class FieldDomainPointsByXYZ
Represents a set of three-dimensional point coordinates
Public class FieldValues
Contains values corresponding to domain points. Each domain point may have an array of values, each corresponding to a separate "measurement" for which this value was calculated.
Public class GenericZone
Provides access to the GenericZone Element in Autodesk Revit.
Public class GenericZoneDomainData
A base class for specific domain requirements for a generic zone.
Public class HVACLoadBuildingType
The type element of building.
Public class HVACLoadSpaceType
The type element of space.
Public class HVACLoadType
The base class for building type and space type.
Public class MassEnergyAnalyticalModel
This class associates a mass instance with an energy analytical model data and geometry.
Public class MassGBXMLExportOptions
Options used when exporting a gbXML file from a mass model document.
Public class MassLevelData
MassLevelData is a conceptual representation of an occupiable floor (Mass Floor) in a conceptual building model. It is defined by associating a particular level with a particular mass element in a Revit project.
Public class MassSurfaceData
Holds properties and other data about a face in the MassEnergyAnalyticalModel element.
Public class MassZone
MassZones are created from the MassEnergyAnalyticalModel. They are conceptual representations of individually heated and cooled sub-volumes of a building.
Public class PathOfTravel
An element which holds a graphical representation of the shortest route between two points in the plane of a floor plan view. The shortest route is calculated to go around model geometry visible in the view. Route calculation is affected by properties of the RouteAnalysisSettings element.
Public class PathOfTravelCalculationServerIds
Ids for external servers implementing path of travel calculations.
Public class Polyloop
A Polyloop represent a planar polygon with ordered points.
Public class RouteAnalysisSettings

RouteAnalysisSettings is an element which contains project-wide settings for route calculations. The PathOfTravel element uses these settings to calculate a route between two points in a plan view.

By default, the route will go around the geometry of all visible model elements which have model geometry in the Route Analysis Zone.

The Route Analysis Zone, determined per view, is the space between these two horizontal planes: a top plane vertically offset by AnalysisZoneTopOffset above the view's level and a bottom plane vertically offset by AnalysisZoneBottomOffset ft above the view's level.

By default, the route will ignore the following elements:
  • elements outside of the crop region of the view;
  • elements without any model geometry (annotations or view-specific elements);
  • model lines (category OST_Lines);
  • demolished elements;
  • elements displayed in the underlay of the view.
There are a few ways to customize Route Analysis on a project-wide basis.

You can adjust the Route Analysis Zone using AnalysisZoneTopOffset and AnalysisZoneBottomOffset .

You can specify a set of model categories you would like ignored during route calculation. To enable ignoring the set of specified categories, set EnableIgnoredCategoryIds to true. To change the set of ignored categories, use SetIgnoredCategoryIds method and IgnoreImports and IgnorePointClouds properties. To query the set of ignored categories, use GetIgnoredCategoryIds .

Public class SpatialFieldManager
Exposes all API for an external analysis application. Its primary role is creation, deletion and modification of SpatialFieldElement elements.
Public class SystemsAnalysisOptions
Contains the options for systems analysis.
Public class ValueAtPoint
Stores values at one domain point. Each value corresponds to a "measurement" for which this value was calculated.
Public class VectorAtPoint
Stores vectors at one domain point. Each vector corresponds to a "measurement" for which this vector was calculated.
Public class ViewSystemsAnalysisReport
Represents a report instance of the systems analysis.

Enumerations

Enumeration Description
Public enumeration AllowLargeGeometry
An enumerated type containing settings information related to handling of large geometries.
Public enumeration AnalysisDisplayStyleColorSettingsType
Defines types for color settings of analysis display style.
Public enumeration AnalysisDisplayStyleDeformedShapeTextLabelType
Defines text visualization types for deformed shape settings of analysis display style.
Public enumeration AnalysisDisplayStyleDiagramFenceType
Defines fence visualization types for diagram settings of analysis display style.
Public enumeration AnalysisDisplayStyleDiagramTextLabelType
Defines text label visualization types for diagram settings of analysis display style.
Public enumeration AnalysisDisplayStyleMarkerTextLabelType
Text label visualization types for Markers and Text settings of analysis display style.
Public enumeration AnalysisDisplayStyleMarkerType
Marker types for Markers and Text settings of analysis display style.
Public enumeration AnalysisDisplayStyleVectorArrowheadScale
Defines arrow head scaling for vector settings of analysis display style.
Public enumeration AnalysisDisplayStyleVectorOrientation
Defines vector orientation for vector settings of analysis display style.
Public enumeration AnalysisDisplayStyleVectorPosition
Defines vector position for vector settings of analysis display style.
Public enumeration AnalysisDisplayStyleVectorTextType
Defines text visualization types for vector settings of analysis display style.
Public enumeration AnalysisMode
This enum is used to define the Energy Analysis Model.
Public enumeration ConceptualConstructionFloorSlabType
ConceptualConstructionType values for Floors.
Public enumeration ConceptualConstructionOpeningType
ConceptualConstructionType values for Openings.
Public enumeration ConceptualConstructionRoofType
ConceptualConstructionType values for Roofs.
Public enumeration ConceptualConstructionShadeType
ConceptualConstructionType values for Shades.
Public enumeration ConceptualConstructionWallType
ConceptualConstructionType values for Walls.
Public enumeration ConceptualConstructionWindowSkylightType
ConceptualConstructionType values for Windows and Skylights
Public enumeration ConstructionType
This enumeration specifies the available analytical construction types like external walls, windows etc. for use in the detailed analytical energy model.
Public enumeration EnergyAnalysisDetailModelTier
Level of computation for energy analysis model.
Public enumeration EnergyAnalysisOpeningType
Energy analysis opening type.
Public enumeration EnergyAnalysisSurfaceType
Analytical surface types.
Public enumeration EnergyModelType
This enum is used to define if the energy model is based on rooms/spaces, building elements or analysis mode in EnergyDataSettings.
Public enumeration gbXMLBuildingHVACSystem
Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
Public enumeration gbXMLBuildingOperatingSchedule
Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
Public enumeration gbXMLBuildingType
Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
Public enumeration gbXMLConditionType
This enumeration corresponds to the conditionType attribute in gbXML. The enumerated attribute identifies the type of heating, cooling, or ventilation the space has.
Public enumeration gbXMLExportBuildingEnvelope
Indicates the determination method for the building envelope
Public enumeration gbXMLExportComplexity
This enumeration specifies the level of detail of the exported analytical energy model in gbXML. Complex means that Curtain Walls and Curtain Systems are exported as several openings, panel by panel; a curtain wall with 50 panels gets exported as 50 openings. Simple means that one "huge" opening with the total opening area equal to the 50 panels is exported. This is more appropriate for most energy analysis. Mullions mean that Mullions in Curtain Walls and Systems are exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness and offset.
Public enumeration gbXMLOpeningType
This enumeration corresponds to the openingType attribute in gbXML and identifies the type of opening defined.
Public enumeration gbXMLServiceType
This enumeration corresponds to the systemType attribute in gbXML and is used for specifying the service for the building or space.
Public enumeration gbXMLSpaceType
This enumeration corresponds to the spaceType attribute in gbXML. The enumerated attribute identifies the type of space defined and allows to better approximate the actual internal loads and schedules associated with the defined space type.
Public enumeration gbXMLSurfaceType
This enumeration corresponds to the surfaceType attribute in gbXML and identifies the type of surface defined.
Public enumeration HVACLoadConstructionClass
Enumerated type listing options for construction class for HVAC analysis.
Public enumeration HVACLoadLoadsReportType
Enumerated type listing possible types of reports generated for HVAC loads.
Public enumeration MassSurfaceDataMaterialType
Indicates how the visualization material for the MassSurfaceData is calculated.
Public enumeration MassSurfaceDataSource
Indicates whether values for the properties of the MassSurfaceData are synchronized with the EnergyDataSettings of the document or instead, serve as overrides of those settings.
Public enumeration MassZoneLevelCutState
The relationship between lower level or upper level and the MassZone. The MassZone is not intersected by this level, this level just happens to be the nearest upper or lower level. The MassZone was created by cutting its source geometry with this level. The level cuts through the MassZone geometry. One or more faces of the MassZone are coincident with this level and the level does not otherwise cut through or intersect the MassZone geometry.
Public enumeration MassZoneMaterialType
MassZone material type.
Public enumeration OutdoorAirFlowStandard
An enumerated type listing all the possible outdoor airflow standard for a space type.
Public enumeration PathOfTravelCalculationStatus
An enumerated type containing possible results of the Path of Travel calculation.
Public enumeration SpatialFieldPrimitiveHideMode
Defines modes which can be used by a SpatialFieldPrimitive to hide the original referenced element.
Public enumeration SystemsAnalysisReportStyle
The report style of systems analysis.