ResetSharedCoordinates Method


Reset shared coordinates for the host model/file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021.1

Syntax

C#
public void ResetSharedCoordinates()
Visual Basic
Public Sub ResetSharedCoordinates
Visual C++
public:
void ResetSharedCoordinates()

Remarks

When you reset shared coordinates, the shared coordinates of the host model will be erased. The shared relationship with all the linked models will be eliminated. Survey point will be reset back to startup location, where it coincides with the Internal Origin. The rotation angle between Project North and True North will be reset back to 0.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException This Document is not a primary document, it is a linked document. -or- This Document is not a project document. -or- This Document has is in an edit mode or is in family mode.
Autodesk.Revit.Exceptions ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions ModificationOutsideTransactionException The document has no open transaction.

See Also