Tests if the given string can be used as a name for a numbering partition.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- name
- Type: System String
A name to validate.
- message
- Type: System String %
Optional string to receive an error message to possibly show to the end user in case the name is found invalid. This argument may be null.
Return Value
Returns True if the name can be used; or False if the string contains invalid characters.Remarks
For a name to be considered valid it must contain only printable characters excluding any characters that may not be used in name of a file.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |