UserModifiable Property


This property indicates whether this parameter can be modified by UI user or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015

Syntax

C#
public bool UserModifiable { get; set; }
Visual Basic
Public Property UserModifiable As Boolean
	Get
	Set
Visual C++
public:
property bool UserModifiable {
	bool get ();
	void set (bool value);
}

Field Value

True if the parameter will be modifiable by the user in the user interface, false if the parameter will display as read-only. The default is true.

See Also