Check if the document contains unsupported Structural Elements.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
Document in which to perform Analytical Support Check.
- progressIndicatorText
- Type: System String
Text to display on progress indicator.
Return Value
True if the support check succeeded, false otherwise.Remarks
Existence of unsupported Elements will not affect the return value. Reporting of unsupported Structural Elements will be done via Warnings. This should be run from within a transaction.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |