GetBarDiameter Method


Gets the model diameter of the Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2022 and may be removed in a later version of Revit. It returns the bar model diameter. We suggest you replace it with GetBarModelDiameter or GetBarNominalDiameter methods instead.")]
public double GetBarDiameter()
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2022 and may be removed in a later version of Revit. It returns the bar model diameter. We suggest you replace it with GetBarModelDiameter or GetBarNominalDiameter methods instead.")> _
Public Function GetBarDiameter As Double
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2022 and may be removed in a later version of Revit. It returns the bar model diameter. We suggest you replace it with GetBarModelDiameter or GetBarNominalDiameter methods instead.")]
public:
double GetBarDiameter()

Return Value

Returns the model diameter of the Rebar.

See Also