Duplicates an existing element type and assigns it a new name.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- name
- Type: System String
The new name of the element type.
Return Value
The duplicated element type.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | name is an empty string. -or- name cannot include prohibited characters. -or- The element type name was empty, contained invalid characters, or was invalid for the specific element type. -or- The name is already in use for this element type. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InternalException | Duplicate element type could not be obtained. |
Autodesk.Revit.Exceptions InvalidOperationException | The ElementType cannot be copied. |