ResetMovedLineTransform Method


Reset the transformation representing the movement of the line relative to its default position along the direction of the specified layer. The moved line transform will be set to Identity.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public void ResetMovedLineTransform(
	AreaReinforcementLayerType layer,
	int linePositionIndex
)
Visual Basic
Public Sub ResetMovedLineTransform ( _
	layer As AreaReinforcementLayerType, _
	linePositionIndex As Integer _
)
Visual C++
public:
void ResetMovedLineTransform(
	AreaReinforcementLayerType layer, 
	int linePositionIndex
)

Parameters

layer
Type: Autodesk.Revit.DB.Structure AreaReinforcementLayerType
The layer on which the line stays.
linePositionIndex
Type: System Int32
The index of the line from the desired layer. It should be an index between 0 and (NumberOfLines-1).

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException linePositionIndex is not in the range [ 0, NumberOfLines-1 ]. -or- A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions DisabledDisciplineException None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions InapplicableDataException The layer layer isn't active.
Autodesk.Revit.Exceptions InvalidOperationException This AreaReinforcement does not host Rebar.

See Also