EquipmentType Property


The type of zone equipment. Note this property would reset other properties.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.1.1.1)
Since: 2020.1

Syntax

C#
public ZoneEquipmentHvacType EquipmentType { get; set; }
Visual Basic
Public Property EquipmentType As ZoneEquipmentHvacType
	Get
	Set
Visual C++
public:
property ZoneEquipmentHvacType EquipmentType {
	ZoneEquipmentHvacType get ();
	void set (ZoneEquipmentHvacType value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also