EndTangent Property


Gets or sets the tangent vector at the end of the curve. The invalid or zero vector is ignored when setting the tangent.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014

Syntax

C#
public XYZ EndTangent { get; set; }
Visual Basic
Public Property EndTangent As XYZ
	Get
	Set
Visual C++
public:
property XYZ^ EndTangent {
	XYZ^ get ();
	void set (XYZ^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was null

See Also