IsIFCAvailable Method


Checks whether IFC functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014

Syntax

C#
public static bool IsIFCAvailable()
Visual Basic
Public Shared Function IsIFCAvailable As Boolean
Visual C++
public:
static bool IsIFCAvailable()

Return Value

True if the IFC functionality is available in the installed Revit.

Remarks

IFC Import/Export requires presence of certain modules that are optional and may not be part of the installed Revit.

See Also