Constructs a new instance of an SelectableInViewFilter.
Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document that owns the view.
- viewId
- Type: Autodesk.Revit.DB ElementId
The view id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | viewId is not a view. -or- viewId is not valid for element iteration, because it has no way of representing drawn elements. Many view templates will fail this check. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |