VertexPositionNormal Constructor


Constructs the vertex from a point and a normal vector.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017

Syntax

C#
public VertexPositionNormal(
	XYZ position,
	XYZ normal
)
Visual Basic
Public Sub New ( _
	position As XYZ, _
	normal As XYZ _
)
Visual C++
public:
VertexPositionNormal(
	XYZ^ position, 
	XYZ^ normal
)

Parameters

position
Type: Autodesk.Revit.DB XYZ
The vertex's position.
normal
Type: Autodesk.Revit.DB XYZ
The vertex's normal vector.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also