AddCorrectionFactor Method (Double, Double)


Add a new electrical correction factor type to this temperature rating type. The given temperature value should be quantified in the document's selected unit of electrical temperature.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)

Syntax

C#
public CorrectionFactor AddCorrectionFactor(
	double temperature,
	double factor
)
Visual Basic
Public Function AddCorrectionFactor ( _
	temperature As Double, _
	factor As Double _
) As CorrectionFactor
Visual C++
public:
CorrectionFactor^ AddCorrectionFactor(
	double temperature, 
	double factor
)

Parameters

temperature
Type: System Double
Temperature of correction factor to be added in the document's selected unit of electrical temperature.
factor
Type: System Double
Factor of correction factor to be added.

Return Value

New constructed correction factor.

See Also