SetActiveServer Method (Guid, Document)


Change the active server for a specific document.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013

Syntax

C#
public void SetActiveServer(
	Guid serverId,
	Document document
)
Visual Basic
Public Sub SetActiveServer ( _
	serverId As Guid, _
	document As Document _
)
Visual C++
public:
void SetActiveServer(
	Guid serverId, 
	Document^ document
)

Parameters

serverId
Type: System Guid
Id of the server.
document
Type: Autodesk.Revit.DB Document
The document for which the server is being set as active.

Remarks

Only one server per document can be set as active at any given time in a single-server service. A document does not have to have an explicitly set active server though - the application-wide active server would be normally used when the service is executed for such a document.

Having an active server for a document overrules the active server set for the application. That means if the service gets executed in this particular document, the document-specific server will be used instead of the application-wide one.

It is possible to set a server as active when another server is already active for that service in this document. Making a server active will automatically deactivate the server that was active before this call.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The given Id is not of a server registered with the service.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null
Autodesk.Revit.Exceptions InvalidOperationException The operation is not allowed because the service is being executed.

See Also