Autodesk.Revit.DB.Infrastructure Namespace


Classes

Class Description
Public class Alignment
Represents an object which provides access to an underlying Revit alignment element.
Public class AlignmentStationLabel
Represents an object which provides access to a specialized Revit annotation element used for labeling Alignment stations.
Public class AlignmentStationLabelOptions
Represents an object containing options for creating an AlignmentStationLabel .
Public class AlignmentStationLabelSetOptions
Represents an object containing options for creating a set of AlignmentStationLabel .
Public class HorizontalCurveEndpoint
Represents an endpoint (start or end) of a horizontal curve in Alignment geometry.

Enumerations

Enumeration Description
Public enumeration HorizontalCurveType
Represents the curve types for the horizontal curves which define Alignment geometry.