Access key to use to execute a service.
Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
GUID representing the access key.Remarks
The service must be declared as public in order for callers be able to invoke this method. Services that are not public can be executed only by their owners (the ones who registered it).
Most services are not public and may only be executed by their respective owners. To see whether a service was declared as public, call the GetOptions method and check the IsPublic property.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | The service is not public, thus the access key cannot be obtained. |