CreateProfileSketch Method


Creates a new Wall profile Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public Sketch CreateProfileSketch()
Visual Basic
Public Function CreateProfileSketch As Sketch
Visual C++
public:
Sketch^ CreateProfileSketch()

Return Value

Created profile Sketch of the Wall.

Remarks

The loop of the sketch cannot be obtained until regeneration. To regenerate the document use Regenerate . To edit the Wall profile use [!:Autodesk::Revit::DB::SketchEditScope] .

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException Wall does not support profile Sketch as it is not a straight wall; or is tapered; or it is an old curtain wall; or it is an infill wall; or it is a replacement curtain panel. -or- Wall already has a sketch.

See Also