Sets the Layout Rule property of rebar set to MaximumSpacing
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- spacing
- Type: System Double
The maximum spacing between rebar in rebar set
- arrayLength
- Type: System Double
The distribution length of rebar set
- barsOnNormalSide
- Type: System Boolean
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
- includeFirstBar
- Type: System Boolean
Identifies if the first bar in rebar set is shown
- includeLastBar
- Type: System Boolean
Identifies if the last bar in rebar set is shown
Remarks
When changing the layout rule to MaximumSpacing, you must also simultaneously set Spacing, SetLength, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The spacing isn't bigger than 0.0. -or- the set length arrayLength isn't acceptable. |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions InapplicableDataException | This RebarContainerItem is an instance of a spiral or multiplanar shape. |