Gets the Element referenced by the input ElementId.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- id
- Type: Autodesk.Revit.DB ElementId
The ElementId, whose referenced Element will be retrieved from the model.
Return Value
The element referenced by the input argument.Remarks
a null reference ( Nothing in Visual Basic) will be returned if the input ElementId doesn't reference to a valid Element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |