Retrieves all curves for the Analytical Model of a given type.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curveType
- Type: Autodesk.Revit.DB.Structure AnalyticalCurveType
Which curve type should be returned.
Return Value
An array of curves representing analytical model.Remarks
If the analytical model contains no curves of the given type, then the returned array may be empty.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |