Creates a new Point BoundaryConditions Element.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- reference
- Type: Autodesk.Revit.DB Reference
A Geometry reference to a Beam's, Brace's or Column's analytical line end.
- X_Translation
- Type: Autodesk.Revit.DB.Structure TranslationRotationValue
A value indicating the X axis translation option.
- X_TranslationSpringModulus
- Type: System Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
- Y_Translation
- Type: Autodesk.Revit.DB.Structure TranslationRotationValue
A value indicating the Y axis translation option.
- Y_TranslationSpringModulus
- Type: System Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
- Z_Translation
- Type: Autodesk.Revit.DB.Structure TranslationRotationValue
A value indicating the Z axis translation option.
- Z_TranslationSpringModulus
- Type: System Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".
- X_Rotation
- Type: Autodesk.Revit.DB.Structure TranslationRotationValue
A value indicating the option for rotation about the X axis.
- X_RotationSpringModulus
- Type: System Double
Rotation Spring Modulus for X axis. Ignored if X_Rotation is not "Spring".
- Y_Rotation
- Type: Autodesk.Revit.DB.Structure TranslationRotationValue
A value indicating the option for rotation about the Y axis.
- Y_RotationSpringModulus
- Type: System Double
Rotation Spring Modulus for Y axis. Ignored if Y_Rotation is not "Spring".
- Z_Rotation
- Type: Autodesk.Revit.DB.Structure TranslationRotationValue
A value indicating the option for rotation about the Z axis.
- Z_RotationSpringModulus
- Type: System Double
Rotation Spring Modulus for Z axis. Ignored if Y_Rotation is not "Spring".
Return Value
If successful, NewPointBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 0 - "Point". a null reference ( Nothing in Visual Basic) is returned if the operation fails.Remarks
This method will only function with the Autodesk Revit Structure application.
Examples

bool CreatePointBoundaryCondition(Autodesk.Revit.DB.Document document, FamilyInstance column)
{
// Get the start point reference of the column
Reference startReference = null;
AnalyticalModel analyticalModel = column.GetAnalyticalModel() as AnalyticalModel;
if (null != analyticalModel)
{
startReference = analyticalModel.GetCurve().GetEndPointReference(0);
}
else
{
throw new Exception("Cannot get end point for selected column");
}
// Get the Revit creation document
Autodesk.Revit.Creation.Document docCreation = document.Create;
// Create the Point Boundary Conditions for the start point
BoundaryConditions condition = docCreation.NewPointBoundaryConditions(startReference,
TranslationRotationValue.Fixed, 0,
TranslationRotationValue.Fixed, 0,
TranslationRotationValue.Fixed, 0,
TranslationRotationValue.Fixed, 0,
TranslationRotationValue.Fixed, 0,
TranslationRotationValue.Fixed, 0);
if (null == condition)
{
throw new Exception("Can't create the point boundary condition for selected column start point.");
}
// Give the user some information
TaskDialog.Show("Revit","Point boundary condition created successfully.");
return (null != condition);
}

Private Function CreatePointBoundaryCondition(document As Autodesk.Revit.DB.Document, column As FamilyInstance) As Boolean
' Get the start point reference of the column
Dim startReference As Reference = Nothing
Dim analyticalModel As AnalyticalModel = TryCast(column.GetAnalyticalModel(), AnalyticalModel)
If analyticalModel IsNot Nothing Then
startReference = analyticalModel.GetCurve().GetEndPointReference(0)
Else
Throw New Exception("Cannot get end point for selected column")
End If
' Get the Revit creation document
Dim docCreation As Autodesk.Revit.Creation.Document = document.Create
' Create the Point Boundary Conditions for the start point
Dim condition As BoundaryConditions = docCreation.NewPointBoundaryConditions(startReference, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
0)
If condition Is Nothing Then
Throw New Exception("Can't create the point boundary condition for selected column start point.")
End If
' Give the user some information
TaskDialog.Show("Revit", "Point boundary condition created successfully.")
Return (condition IsNot Nothing)
End Function