Converts a stable String representation of a reference to a Reference object.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
-
Type:
Autodesk.Revit.DB
Document
The document.
- representation
-
Type:
System
String
The reference representation.
Remarks
Use
ConvertToStableRepresentation(Document)
to obtain the representation.
The Reference will have only the following information set:
You will also be able to pass the reference to Document.GetElement(reference) and Element.GetGeometryObjectFromReference(reference)
to obtain the element and geometry object referred to.
Examples

public Reference ParseReference(Document doc, String str)
{
Reference reference = Reference.ParseFromStableRepresentation(doc, str);
if (null == reference)
{
TaskDialog.Show("ParseReference", "Reference is Null.");
}
return reference;
}

Public Function ParseReference(doc As Document, str As [String]) As Reference
Dim reference__1 As Reference = Reference.ParseFromStableRepresentation(doc, str)
If reference__1 Is Nothing Then
TaskDialog.Show("ParseReference", "Reference is Null.")
End If
Return reference__1
End Function
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | One or more arguments was a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Reference representation could not be successfully parsed, or element id obtained from reference representation could not be found in this document. |