IsOrientationSameAsBasisSurface Method


Indicates whether the orientation of the OffsetSurface is same as that of its basis surface, in the sense that their oriented normals at any (u, v) have the same direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021

Syntax

C#
public bool IsOrientationSameAsBasisSurface()
Visual Basic
Public Function IsOrientationSameAsBasisSurface As Boolean
Visual C++
public:
bool IsOrientationSameAsBasisSurface()

Return Value

True if the orientation of the OffsetSurface is same as that of its basis surface, false otherwise.

See Also