HasExtension Property


Indicates if the element supports an extension option.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015

Syntax

C#
public bool HasExtension { get; }
Visual Basic
Public ReadOnly Property HasExtension As Boolean
	Get
Visual C++
public:
property bool HasExtension {
	bool get ();
}

Remarks

Analytical model elements for walls support extension options, while those for floor or slabs do not.

See Also