AddCorrectionFactor Method


Add a new electrical correction factor type to this temperature rating type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2022 and may be removed in a future version of Revit. Please use the AddCorrectionFactor(double, double) overload instead.")]
public CorrectionFactor AddCorrectionFactor(
	long temperature,
	double factor
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2022 and may be removed in a future version of Revit. Please use the AddCorrectionFactor(double, double) overload instead.")> _
Public Function AddCorrectionFactor ( _
	temperature As Long, _
	factor As Double _
) As CorrectionFactor
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2022 and may be removed in a future version of Revit. Please use the AddCorrectionFactor(double, double) overload instead.")]
public:
CorrectionFactor^ AddCorrectionFactor(
	long long temperature, 
	double factor
)

Parameters

temperature
Type: System Int64
Temperature of correction factor to be added.
factor
Type: System Double
Factor of correction factor to be added.

Return Value

New constructed correction factor.

See Also