SpatialElement Class


Represents an enclosed area or volume in the Revit model. This is the parent class for rooms, spaces and areas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public class SpatialElement : Element
Visual Basic
Public Class SpatialElement _
	Inherits Element
Visual C++
public ref class SpatialElement : public Element

Inheritance Hierarchy

See Also