Returns rigid link curve corresponding to selector.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- selector
- Type: Autodesk.Revit.DB.Structure AnalyticalModelSelector
Identifies from which end of the analytical model to get the Rigid Link.
Return Value
Rigid link satisfying selector.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | selector is not valid for this AnalyticalModel. -or- Thrown if selector identifies a entire curve instead of just an endpoint. This is because this only returns one curve, and an entire analytical curve may have any number of rigid links. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |