Merges the two regions which share the specified segment.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- segmentId
- Type: System Int32
The id of a segment in the underlying grid.
- layerIdxForMergedRegion
- Type: System Int32
The index of the layer to which the resulting region will be associated.
Return Value
The id of the resulting region. If -1 is returned, then the operation would have produced an invalid region and was not performed.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The layer index is out of range. |
Autodesk.Revit.Exceptions InvalidOperationException | Split and merge regions operations can be used only for vertically compound structures without variable thickness layers. -or- The segment is not shared by adjacent regions. |