GetRegionIds Method


Gets the region ids of this compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public IList<int> GetRegionIds()
Visual Basic
Public Function GetRegionIds As IList(Of Integer)
Visual C++
public:
IList<int>^ GetRegionIds()

Return Value

The ids of the regions defining this CompoundStructure.

Remarks

A vertically compound structure consists of regions with polygonal boundaries.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException This operation is valid only for vertically compound structures.

See Also