Gets the Element object (either Host or Rebar) which provides the constraint. Will return the Element which contains the face at targetIndex.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- targetIndex
- Type: System Int32
The index of the target. Should be between 0 and NumberOfTargets().
Return Value
Returns the Element object (either Host or Rebar) which provides the constraint. Will return the Element which contains the face at targetIndex.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | targetIndex is out of range. |
Autodesk.Revit.Exceptions InvalidOperationException | RebarConstraint is no longer valid. |