Assign a new list of constraints to this vertex.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- constraints
- Type: System.Collections.Generic IList RebarShapeConstraint
A new list of constraints.
Remarks
Any existing constraints are discarded. The new constraints replace them. Any parameters driving the constraints must already be added with RebarShapeDefinition.AddParameter().
The allowable constraint types are:
- RebarShapeConstraintRadius
- RebarShapeConstraintArcLength
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | One or more of the constraints is of a type not supported for RebarShapeVertex. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |