Creates a new instance of RebarSystemSpanSymbol in the project.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- viewId
- Type: Autodesk.Revit.DB ElementId
The id of the view in which the symbol should appear.
- hostId
- Type: Autodesk.Revit.DB LinkElementId
The ElementId of AreaReinforcement (either in the document, or linked from another document).
- point
- Type: Autodesk.Revit.DB XYZ
The span symbol's head position.
- symbolId
- Type: Autodesk.Revit.DB ElementId
The id of the family symbol of this symbol.
Return Value
A reference to newly created span symbol.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | hostId should refer to a AreaReinforcement element. -or- viewId does not refer to a valid view type for FabricReinSpanSymbol - only floor plan, reflected ceiling plans and elevations are permitted. -or- symbolId should refer to a FamilySymbol of category OST_FabricReinSpanSymbol. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |