GetOptions Method


Gets a copy of options from settings for exporting. Modification on this options would not change the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public PDFExportOptions GetOptions()
Visual Basic
Public Function GetOptions As PDFExportOptions
Visual C++
public:
PDFExportOptions^ GetOptions()

Return Value

The options.

Remarks

Since the [!:PDFExportOptions.FileName] is not serialized, when [!:Combine] is true ( True in Visual Basic) (which means all the views would be exported into one PDF file, whose file name is specified by [!:PDFExportOptions.FileName] ), the returned PDFExportOptions would have [!:PDFExportOptions.FileName] as an empty string. The user has to set the [!:PDFExportOptions.FileName] before calling the [!:Document.Export(string, IList{ElementId}, PDFExportOption)] API exporting a "combined" PDF file.

See Also